TLS 1.0 ve TLS 1.1 desteği sona eriyor

23 Şubat 2020
31
Bakıldı

Çeşitli bir çok yazılım ve Program’da desteklenen TLS 1.0 ve TLS 1.1 artık kullanılamayacaktır. E-Posta gönderimlerinde TLS 1.0 yada TLS 1.1 kullanıyorsanız güncelleme gereklidir.

2020 yılı içerisinde TLS 1.0 ve TLS 1.1 destekleği bir cok browse tarayıcılarda ftp ve E-Posta programlarında aktif olarak çalışmayacaktır.
belirtilen yazılımlarda sadece TLS 1.2 veya üst sürümler kullanılacaktır.

TLS nedir?

Merak etmiş olduğunuz TLS nedir? sorusuna Transport Layer Security (TLS) Türkçesi Aktarım ve Taşıma Katmanı Güvenliğidir, İnternet Ağı üzerinden iletişim için gizliliği ve veri güvenliğini kolaylaştırmak üzere tasarlanmış, yaygın olarak kabul edilen bir güvenlik protokolüdür.

TLS’nin birincil kullanım durumu, web uygulamaları yükleyen web tarayıcıları gibi web uygulamaları ve sunucular arasındaki iletişimi şifrelemektir. TLS, e-posta, mesajlaşma ve IP üzerinden ses (VOIP) gibi diğer iletişimleri şifrelemek için de kullanılabilir Tarayıcıyı her açtığınızda TLS’yi pasif olarak kullanırsınız. 

TLS nasıl çalışır?

TLS, TCP gibi bir taşıma katmanı güvenlik protokolünün üstünde kullanılabilir.
TLS’nin üç ana bileşeni vardır:
Şifreleme, Kimlik Doğrulama ve Bütünlük.

Şifreleme: üçüncü taraflardan aktarılan verileri gizler.
Kimlik Doğrulama: bilgi alışverişinde bulunan tarafların iddia ettikleri kişi olmasını sağlar.
Bütünlük: verilerin sahte veya taklit edilmediğini doğrular.

Browser Tarayıcılar TLS 1.0 ve TLS 1.1 Desteği

Aşağıda belirtilen (Browser) tarayıcılarda güvenlik açığı nedeni ile belirtilen tarihlerde TLS 1.0 ve TLS 1.1 desteği son bulacaktır.

Browser adı ———– ———– Desteğin sona ereceği Tarih
Microsoft IE ve Edge ———– 2020 yılı ilk 6 ay içerisinde
Mozilla Firefox ——————- 1.5.2020
Safari/Webkit ——————— 1.5.2020
Google Chrome —————– 14.1.2020

E-Posta Programları TLS 1.0 TLS 1.1 Desteği

Windows live, Office Outlook 2007 ve önceki sürümleri kullanan tüm E-Posta kullanıcıları Tls 1.0 ve TLS 1.1 desteğinden faydalanamayacaklardır. Bu destek güvenlik açıkları nedeni ile 2020 ocak ayında sona ermiştir.
Windows 7 ve öncesi windows işletim sistemlerini kullanan tüm kullanıcılar E-Posta gönderimlerinde bağlantı problemi yaşayacaklardır.

Ayrıca Adobe Bir çok yazılımında TLS 1.0 ve 1.1 Desteğini durduracağını açıklamıştır.
Adobe’nin açıklaması : ” 9 Nisan 2018 tarihinden önce tüm kullanıcı sistemlerinizin TLS 1.2 ile uyumlu olduğundan emin olmanız çok önemlidir. Bu tarihten sonra TLS 1.2 uyumlu olmayan sistemler, Adobe Sign hizmetine erişemeyecektir. ”

Hata Alıyorum Ne Yapmalıyım Nasıl Güncellerim ?

TLS 1.2 için işletim sisteminizi güncellemelisiniz;

  • Windows sunucusu: Windows Server 2008 R2 veya üzeri bir sürümü kullanmalısınız
  • Windows masaüstü: Windows 8 veya üzeri bir sürümü kullanmalısınız
  • OS X: OS X 10.8 veya üzeri bir sürümü kullanmalısınız

TLS 1.2 için uygulama çerçevesi desteği:

  • Java için: Java 8 veya üzeri bir sürümü kullanın. Java 7 kullanılabilir, ancak uygulama tarafından açıkça etkinleştirilebilmesi için TLSv1.2 gereklidir.
  • .NET için: .NET 4.6 veya üzeri bir sürümü kullanın. .NET 4.5 kullanılabilir ancak uygulama tarafından açıkça etkinleştirilebilmesi için TLSv1.2 gereklidir. .NET, Windows tarafından sağlanan TLS 1.2 desteğine bağlıdır
  • OpenSSL kullanan uygulamalar için: OpenSSL 1.01 veya üzeri bir sürümü kullanın

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

%d blogcu bunu beğendi: